
 WinMatch™ Help Contents    

Welcome to the Help system for WinMatch 1.0.    Select the topic you want help on:    

Introduction

Legal Stuff

Toolbar

Menus

Shareware

Registration

Order Form



Introduction

WinMatch is a program designed to compare documents line by line.    To compare two files, do the 
following steps:

Open a file to be used as the "Old" file, by clicking on the Open Old toolbar button    or using the 
Open Old command in the File menu.

Open a second file to be used as the "New" file, by clicking on the Open New toolbar button or using
the Open New command in the File menu.

Compare the two files by clicking on the Match Files toolbar button    or using the Match Files 
command in the Action menu.

WinMatch will process each file and display the Old file with line numbers on the left side and the New 
file with corresponding line numbers on the right side.    If there is a mismatch, the incompatible lines will 
be displayed as a deletion from the old file and/or an addition to the new file.

To view the differences, you can either browse through the files using the scrollbar, or use the Next 
Difference and Previous Difference buttons or commands to jump to the next section of mismatching 
text.    Likewise, you can use the Next Match and Previous Match buttons or commands to skip over a 
difference and find a matching section of text again.



Disclaimer of Warranty and ASP Ombudsman statement
Users of WinMatch must accept this disclaimer of warranty:

"WinMatch 1.0 is supplied as is.    SOFTWEST disclaims all warranties, expressed or implied, 
including, without limitation, any warranties of merchantability or fitness for any purpose.

SOFTWEST does not assume any liability for the use of this software beyond the original 
purchase price of this software.

In no event will SOFTWEST be liable to you for any additional damages, including any lost 
profits, lost savings or other incidental or consequential damages arising from the use of, or 
inability to use, this software, even if SOFTWEST has been advised of the possibility of such 
damages."

This program is produced by a member of the Association of Shareware Professionals (ASP).    ASP 
wants to make sure that the shareware principle works for you.    If you are unable to resolve a 
shareware-related problem with an ASP member by contacting the member directly, ASP may be able to
help.    The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does 
not provide technical support for members' products.    Please write to the ASP Ombudsman at 545 
Grover Road, Muskegon, MI 49442 or send a CompuServe message via CompuServe Mail to ASP 
Ombudsman, 70007,3536.



Toolbar
The toolbar is located just below the main menu.    It provides a quick way to open, close, and compare 
files, jump to the next or previous difference or match, and to rearrange the windows.

Click on one of the buttons below for more help:

 

 

        

        

 

 

 

        

 

 



Open Old 
The Open Old command in the File menu and the corresponding toolbar button opens the file to be used
as the "old file" for comparison; i.e. the one which will show lines deleted from it using a red strikeout 
font.    It does not really have to be older than the "new" file, but typically is.
After an Old file has been successfully opened, the Open Old button    will turn green (i.e., "lit"), and the 
Close Files button will be enabled.    If a New file has also been opened, the Match Files button will be 
enabled.    Click on it to begin match the two files.



Open New 

The Open New command in the File menu and the corresponding toolbar button opens the file to be 
used as the "new file" for comparison; i.e. the one which will show lines added to it using a green 
(optionally bold) font.    It does not really have to be newer than the "old" file, but typically is.
After a New file has been successfully opened, the Open New button    will turn green (i.e., "lit"), and the 
Close Files button will be enabled.    If an Old file has also been opened, the Match Files button will be 
enabled.    Click on it to begin match the two files.



Close Files 
The Close Files command in the File menu and the corresponding toolbar button closes any open files, 
prior to opening up another pair to match.    The Close Files button will be disabled, and the Open Old 
and Open New buttons will no longer be "lit."



Match Files 
The Match Files command in the action menu and the corresponding toolbar button starts matching the 
two open Old and New files.

Assuming the option to display both the Old and New files in the same window is not enabled (the 
default case), then two "child windows" will be opened up below the toolbar, one for the Old file and one 
for the New.    Matching lines will be lined up between the two files.    For every difference found, 
"deleted" lines will be struckout in red in the Old file, and "added" lines will be shown in green (optionally 
bold)    in the New file.

If there are more deleted lines than added lines, then there will be some blank space (without any line 
numbers) in the New file until the two files match up again.    Likewise, if there are more added lines than
deleted ones, there will be some blank space (without any line numbers) in the Old file.

You can use either the mouse and scrollbars, or the Page Up/Down and cursor arrow keys to browse 
through the file.    Both windows always scroll synchronously, both vertically and horizontally.

If    the option to display both the Old and New files in the same window is enabled, then only one 
window will be used to display the Old and New files.    Matching lines are shown just once.    Differences
are shown with the deleted lines shown first in red strikeout, followed by the added lines shown in 
(optionally bold) green.



Next Difference 
The Next Difference command in the View menu and the corresponding toolbar button finds the next 
difference between the Old and New files.    If there are no more differences, it sticks where it is.

If a next difference is found, the first line of the difference will be located at the second line from the top 
of each of the two child windows.    This allows for one line of matching text to be displayed before the 
difference.

The accelerator key combination Ctrl+N can also be used to find the next difference.



Prev Difference 
The Prev Difference command in the View menu and the corresponding toolbar button finds the previous
difference between the Old and New files.    If there are no previous differences, it sticks where it is.

If a previous difference is found, the first line of the difference will be located at the second line from the 
top of each of the two child windows.    This allows for one line of matching text to be displayed before 
the difference.

The accelerator key combination Ctrl+P can also be used to find the previous difference.



Next Match 
The Next Match command in the View menu and the corresponding toolbar button finds the next match 
between the Old and New files.    there are no more matches, the sticks where it is.

If a next match is found, the first line of the match will be located at the top of each of the two child 
windows.



Prev Match 
The Prev Match command in the View menu and the corresponding toolbar button finds the previous 
match between the Old and New files.    If there are no previous matches, it sticks where it is.

If a previous match is found, the first line of the match will be located at the top of each of the two child 
windows.



Tile Vertical 
The Tile Vertical command in the Window menu and the corresponding toolbar button arranges the Old 
and New file windows side-by-side vertically, like the button icon.



Tile Horizontal 
The Tile Horizontal command in the Window menu and the corresponding toolbar button arranges the 
Old and New file windows side-by-side horizontally, like the button icon.



Cascade 
The Cascade command in the Window menu and the corresponding toolbar button arranges the Old 
and New file windows cascaded on top of each other, like the button icon.



Close All
The Close All command in the Window menu closes all open child windows.    It does not close the files, 
however, as does the Close Files file menu command.



Menus
Click on one of the menu items below for more help:.

File Menu
Open Old
Open New
Close Files

Action Menu
Match Files

View Menu
Next Difference
Prev Difference
Next Match
Prev Match

Options Menu
Configure...

Window Menu
Tile Vertical
Tile Horizontal
Cascade
Close All

Help Menu
Contents
About



Configure...
The Configure command in the Options menu opens up a dialog box, to enable viewing or changing any
of the WinMatch options.    If you click on the OK button, the current settings will be saved to a file called 
WINMAT.INI in the WinMatch directory.

Options:

Show Old/New in same window.    With the default setting of off, individual child window are used for 
both the OId and New files.    If this option is enabled, then both the Old and New files are merged 
together, and shown in the same window.

Full Listing.    Display all lines, not just those not found in the other file.    If this option is turned off, then 
only one line of matching text before each difference, and one line of matching text after each difference 
will be shown.    Default is on, show all lines.

Use bold font for Adds.    On some monochrome displays, such as those used on laptops, the standard 
green font used to show added lines looks too much like the normal black letters to be easily 
distinguishable.    Selecting this option uses a bold version of this font, which stands out more.    Default 
is off, use normal weight characters.

Ignore upper/lower case.    Ignores case during file comparison.    Default is off, do not ignore case.

Ignore spaces and tabs.    Ignore spaces and tabs when matching.    Default is off, do not ignore 
whitespace.

Tab size.    Change the tab size.    The default is 8 spaces per tab.    Use this option when the input files 
were created    in an environment having a different tab size.    This option affects only the display of the 
lines, not the comparison.

Consecutive lines which must be matched. This is the number of consecutive lines that must match or 
they will be rejected as an addition/deletion.    Used to avoid falsely matching up on common sequences 
of lines that might be found several times in the same document (such as blank lines) or language files 
(such as end of functions).    WinMatch defaults to 4 lines.

Max lines to compare before advancing.    Increase the comparison depth with this option.    WinMatch 
defaults to comparing 150 lines before assuming there is no match for the current line compared in the 
other file.    If your files have deleted or added text larger than 150 lines use this option.    



Contents
The Contents command in the Help menu opens the Help file and displays the Contents page.    It is the 
same as pressing function key F1.



About
The About command in the Help menu displays the current version number of WinMatch and a copyright
message.



About Shareware
Shareware distribution gives users a chance to try software before buying it.    If you try a Shareware 
program and continue using it, you are expected to register. 

Copyright laws apply to both Shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below.    Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality.    (In both 
cases, there are good programs and bad ones!) The main difference is in the method of distribution.    
The author specifically grants the right to copy and distribute the software, either to all or to a specific 
group.

Shareware is a distribution method, not a type of software. You should find software that suits your 
needs and pocketbook, whether it's commercial or Shareware.    The Shareware system makes fitting 
your needs easier, because you can try before you buy.    And because the overhead is low, prices are 
low also.    Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't 
pay for it. 

WinMatch 1.0 is a "shareware program" and is provided at no charge to the user for evaluation.    Feel 
free to share it with your friends, but please do not give it away altered or as part of another system.    
The essence of "user-supported" software is to provide personal computer users with quality software 
without high prices, and yet to provide incentive for programmers to continue to develop new products. 



Registration
If you find this program useful and find that you are using WinMatch and continue to use WinMatch after 
a 21-day trial period, you must register it by sending a payment of $20.00 to SOFTWEST.    To print out a
registration form, jump to the Order Form topic, and select Print    Topic from the Help File menu.    (This 
is also on disk as the file ORDER.DOC).

When you register, you will receive the latest version of WinMatch, and be eligible for three months of 
technical support (either by telephone, limited to a total connect time of 30 minutes; or via FAX, 
CompuServe email, or regular mail).    You will also receive a printed version of the on-line 
documentation, and a copy of the DOS version of Match, which includes printing and wildcards on the 
command line.

You will also receive, when it is available, a free upgrade to WinMatch 2.0, which will feature 
matching of word processing files including Windows Write and MS Word for Windows.    I expected this 
to be available around October, 1993.

You can order the complete source code for WinMatch for only $40.00.    It is set up to compile under
both Borland C++/OWL Version 3.1 (source available now) and Microsoft Visual C++/MFC (source 
available Sept. 1993), and can be used to make custom versions of the program for your own use.

If you are already a registered user of DOS Match 2.0, you can upgrade to WinMatch for just $10.00.  
See the order form file (ORDER.DOC) for details.

The registration fee will license one copy for use on any one computer at any one time.    You must treat 
this software just like a book.    An example is that this software may be used by any number of people 
and may be freely moved from one computer location to another, so long as there is no possibility of it 
being used at one location while it's being used at another.

Corporate users of WinMatch must register and pay for their copies of WinMatch within 30 days of first 
use or their license is withdrawn.    Site licenses (ten or more copies at the same address) may be 
obtained by contacting SOFTWEST.

Anyone distributing WinMatch 1.0 for any kind of remuneration must first contact SOFTWEST (see 
VENDOR.DOC for more information). This authorization will be automatically granted to distributors 
recognized by the Association of Shareware Professionals (ASP) as adhering to its guidelines for 
shareware distributors, and such distributors may begin offering WinMatch 1.0 immediately.

You are encouraged to pass an unaltered copy of the shareware version of WinMatch 1.0 along to your 
friends for evaluation. Please encourage them to register their copy if they find that they can use it.

By registering your copy of WinMatch 1.0, you will be encouraging future versions of the program.    I 
hope you enjoy using WinMatch, and let me know what you would like to see in the next version.

Tom Crosley
July, 1993



Order Form (print out using File - Print Topic)
WinMatch Version 1.0c     Media:  5 1/4" (360K) or 3 1/2" (720K)

     Basic registration (includes latest version,
         printed manual, bonus program and 1 upgrade):  $20.00
     WinMatch source code (BC++/OWL & MSVC++/MFC), add:  40.00
                                          Sub-total:          
     I got my copy                        CA sales tax        
     of WinMatch from: ______________     S&H             1.50

     Enclosed is a check or money order for total of:         

     Your Name:        _______________________________________

     Your Address:     _______________________________________

     City, State, ZIP: _______________________________________

 ---------------------- fold here first ----------------------

                                                               -------
                                                              | place |
                                                              | stamp |
                                                              | here  |
                                                               -------

                                SOFTWEST

                                5120 Campbell Ave.,  Suite #216

                                San Jose, CA  95130

 ---------------------- fold here last -----------------------






